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Software License Agreement 
 
This Software License Agreement (the "Agreement") is a legal Agreement between an individual or entity and Radient Software, Inc. ("Radient Software"). 
The Software application that accompanies this license (the "Software") is protected by United States copyright laws and international treaty provisions. By 
continuing the installation of the Software, by loading or running the Software, or by placing or copying the Software onto your computer hard drive, you 
agree to be bound by the terms of this Agreement. 
 
1. Grant of License. This Agreement permits you to use one copy of the Software, as well as the accompanying "on-line" or electronic documentation, on a 
single computer. While Radient Software continues to own the Software, you have certain rights to use the Software after your acceptance of this License. 
Your rights and obligations with respect to the use of this Software are as follows. You may: 
 
a) use one copy of the Software on a single computer; 
b) make one copy of the Software for archival or backup purposes; or copy the software onto the hard disk of your computer and retain the original disk 

for archival or backup purposes; 
c) use the Software on a network, provided that you have a licensed copy of the Software for each computer that will access the Software over that 

network; and 
d) transfer the Software License to another person or entity, provided that you retain no copies of the Software and that the transferee agrees to the terms 

of this Agreement. 
 
2. Copyright. The Software (including any images, video, audio, and text incorporated into the Software) and related documentation are copyright and are 
exclusively owned by Radient Software. You may not use, copy, modify, or transfer the programs, documentation, or any copy of the Software except as 
expressly provided by this Agreement. The Software is protected by United States copyright laws and international treaty provisions. 
 
SSH2 support powered by sshlib, Copyright © 2000-2003 by Bitvise Ltd, portions Copyright © 1995-2003 by Wei Dai. 
 
3. Other Restrictions. You may not rent or lease the Software; reverse engineer, decompile, disassemble, modify or translate the Software or 
documentation; sell or distribute the Software for money or other considerations; or in any manner or through any medium whatsoever commercially exploit 
the Software or use the Software for any commercial purpose.  
 
4. Warranty and Disclaimers. This Software is provided on an "as-is" basis, without representation or warranty of any kind, either express or implied. In no 
event shall Radient Software or its employees be liable for any damages whatsoever, whether direct, indirect, special, incidental, or consequential (including, 
without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use 
or inability to use the Software, even if Radient Software has been advised of the possibility of such damages. 
 
This Software and related documentation is in no way connected with Comm-Net Information Service, Inc. of Baltimore, MD, or any other organization, 
product, or service other than Radient Software, Inc. of Honolulu, HI. 
 
5. U.S. Government Restricted Rights. Use, duplication or disclosure by the Government is subject to restrictions set forth in subparagraph (a) through (d) 
of the Commercial Computer Restricted Rights clause at FAR 52.227-19 when applicable, or subparagraph (c) (1) (ii) of the Rights in Technical Data and 
Computer Software clause at DFARS 252.227-7013, and in similar clauses in the NASA FAR Supplement. Manufacturer is Radient Software, Inc., P.O. 
Box 25925, Honolulu, HI 96825-0925. 
 
6. U.S. Export Controls. This Software is subject to the Export Administration Regulations (EAR) as set forth by the U.S. Bureau of Export Administration 
and may not be downloaded, used or transferred without a license or other authorization. The is available for export from the United States to all customers 
worldwide, except to U.S. embargoed countries, including Cuba, Iran, Iraq, Libya, North Korea, Sudan, and Syria. By downloading, installing or using the 
Software, you agree that you understand and comply with all U.S. export controls. 
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“There are many good Telnet clients available for downloading via the Internet, but one stands out as being especially rich 
in features. It’s called CommNet and it’s available from Radient Software, Inc.” 
-- “ProLog’s Guide to the Internet” by Ronald L. Wagner  
 
“Radient Software’s CommNet is powerful enough for most users and simple enough for the first-time BBS caller.” 
-- West Coast Online 
 
“[CommNet] loads quickly and performs admirably.” 
“An unusually fast Zmodem protocol works via Telnet or dialup connections. And Ymodem-G is available during dialup 
sessions.” 
-- Boardwatch Magazine 
 
“...One of the few available programs that allows you to transfer files with the Zmodem protocol over your Telnet 
connection.” 
-- CNET Online 
 
“One of the best Telnet clients available.” 
-- Stroud’s Consummate Winsock Applications 
 
 
 



4 

Introduction to CommNet & Secure CommNet 
 
Thank you for choosing CommNet and Secure CommNet from Radient Software. CommNet supports modem dial-up and Internet Telnet 
capabilities; and Secure CommNet integrates modem dial-up, Internet Telnet and Secure Shell (SSH2) capabilities into a single, fast, full-
featured, and easy-to-use application.  
 
New Features in version 2.3: 
♦ Added four script commands:  

♦ PAUSESECONDS (waits a specified number of seconds before going on to the next script command) 
♦ SETRECEIVEDIRECTORY (changes the destination directory for incoming file transfers)  
♦ RUNAPPNOWAIT (starts another program on the system without waiting for it to finish) 
♦ RUNAPPANDWAIT (starts another program on the system and waits for it to finish) 

♦ Increased delay for SSH2 modem uploads to avoid potential buffer overflowing 
♦ Added registration support for systems with multiple users or network installations 
 
Additional Features in version 2.2: 
♦ Fixed scrollback buffer problem when session windows are initially maximized 
♦ Upgraded installation package to use Windows Installer 
 
Additional Features in version 2.1: 
♦ Added script command to begin sending a file via Zmodem 
♦ Added support for direct printing of attached files from the remote host, bypassing the Windows printer driver 
 
New Major Features in version 2.0: 
♦ SSH2 (Secure SHell) support for the following encryption algorithms: AES256, Twofish, Blowfish, Triple-DES, Arcfour, Cast-128 
♦ TCP/IP port forwarding (also known as connection tunneling) during secure connections 
♦ FTP support during Telnet and SSH2 connections 
♦ Multithreaded serial communications support 
♦ Expanded scripting commands 
♦ Configurable scrollback buffer up to 500 pages 
♦ Expanded command line options 
♦ Redesigned user interface with docking toolbars 
♦ URL-aware session windows with enabled hyperlinks  
 
Dial-up, Telnet & SSH2 features: 
♦ Supports one dial-up session and multiple Telnet and SSH2  connections simultaneously 
♦ Supports Telnet Host Mode Server to allow other Telnet clients to connect to your system for direct communication, chatting, and file 

transfers 
♦ Supports high performance Zmodem file transfers with dial-up, Internet Telnet and SSH2 sessions. Zmodem crash recovery and auto-

downloading enabled. Ymodem-G is also available for dial-up sessions 
♦ Supports TTY, VT100, VT220, and full-color PC ANSI and SCO ANSI terminal emulations 
♦ Scripting support to automate log-ins and session connections 
♦ Built-in phone book for easy access to frequently-used addresses 
♦ Entire session contents or selected portions of the session can be saved to a file or output to a printer 
♦ Can be used as the Telnet application for a World Wide Web browser 
 
Customizable features: 
♦ Customizable session font, background color and text color 
♦ User definable Toolbar for access to frequently-used applications 
♦ Selectable row and column defaults for session windows 
♦ Supports keyboard re-mapping 
♦ User definable function keys for commonly-used character string sequences 
♦ Support for multimedia sound effects on specified events (requires multimedia-capable sound card) 
 
Other features: 
♦ Phonebook which provides easy access to frequently-used addresses 
♦ Optimized screen graphics routines to improve response time and reduce overrun errors  
♦ Docking toolbars with quick access to commonly used commands and applications  
♦ Drag and drop file uploading 
♦ Session capture facility to record session text to a file. Multiple sessions can be captured simultaneously 
♦ Supports attached/transparent printing 
♦ Informative status bar with connect time, connection settings, terminal emulation type, and modem/connection status  
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Getting Started 
 
System Requirements 
♦ 386/486/Pentium IBM PC or compatible 
♦ Microsoft Windows 95, Windows 98, Windows NT 4.0, Windows 2000, or Windows XP 
♦ 8 MB RAM with minimum 10 MB free hard disk space 
♦ Modem for dial-up features 
♦ Internet access for Telnet and SSH2 features 
 
Installing CommNet or Secure CommNet 
1. Download and run the CommNet 2.3 or Secure CommNet 2.3 self-executable file. 
2. Registered users: enter the registration key provided. 
 
Changing the Directory of the Configuration Files 
You can change the directory of the configuration files (MAIN.CFG, KEYMAP.DAT, PHONBOOK.DAT) during start-up 
using the command line. The parameter is: config=<directory path>. 
1. Click the DOS icon or open a command line window. 
2. Type CommNet config=<directory path>. 
3. If <directory path> is not specified, the configuration files will be stored in the Program directory. 
 
Setting the Modem Preferences (Dial-up Connections Only) 
1. Choose Modem Hardware from the Setup menu. The Hardware Settings dialog box appears. 
2. Select the preferred settings for serial port, bits per second, data bits, stop bits, parity, and flow control. You can set 

custom hardware settings for each dial-up Phonebook entry. 
3. Click OK to retain the settings. 
  
Setting the Modem Initialization & Dialing Strings (Dial-up Connections Only) 
1. Choose Modem Commands from the Setup menu. The Modem Commands dialog box appears. 
2. Type in the preferred modem initialization string, which is sent when a dial-up session window is opened using the 

Open Dial-Up Window command. Type in the preferred dialing string, which is the dialing prefix used during 
Phonebook dial-up connection attempts. 

3. Click OK to retain the settings. 
 
Setting the Terminal Settings 
1. Choose Terminal Settings from the Setup menu. The Terminal Settings dialog box appears. 
2. Select the preferred terminal emulation type, backspace character, and other terminal options, such as carriage return line 

feed, local echo and word wrap. 
3. Click OK to retain the settings. Settings are in effect for the currently active session window or until they are changed 

manually or by a Phonebook entry. 
 

 Terminal Emulation Types: TTY is raw text (there is no screen formatting). VT100 and VT220, two common settings, 
emulate the DEC terminal. PC ANSI emulates the IBM PC ANSI terminal and supports color graphics. SCO ANSI 
emulates the SCO Unix terminal and supports color graphics. 

 
Adding Applications to the Toolbar 
Tools 1-4 allow you to add applications to the toolbar for instant access. 
1. Select the Change function from Tool 1, 2, 3 or 4 in the Tools menu.  
2. Choose an application from the menu. Its icon will appear on the Applications toolbar. 
3. To launch an application, click an icon from the Applications toolbar or select Run from the Tools menu. 
 
Exiting CommNet or Secure CommNet 
Choose Exit from the File menu. 
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CommNet and Secure CommNet Main Screen 
 
Understanding the Main Screen 
CommNet and Secure CommNet may be customized by adding frequently used applications to the Toolbar (such as a word 
processor, to export the contents of Telnet and SSH2 sessions). In addition, CommNet and Secure CommNet offer an 
informative status bar with connect time, connection settings, window size, emulation type and modem/connection status 
indicator lights. 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 

Cd: carrier direct; you are 
connected to a remote system 

Sd: send data; your 
computer is sending data 

Rd: receive data; your 
computer is receiving data 

Applications Toolbar: You may 
customize the software by adding 
frequently-used applications to the 
Applications toolbar. 

Connect time 

 
Dial-up, Telnet or 
SSH2 settings 

Secure connection 
Secure CommNet only 

Emulation type 

Window size 

The Toolbar: The toolbar gives you 
access to frequently-used commands. 

Tip: You can customize 
the main screen by 
changing the location of 
the toolbars. Simply 
drag the move handle 
on a docked toolbar or 
drag the title bar on a 
floating toolbar to 
another location. Floating 
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Connecting via Dial-up & Telnet 
 
Using the Phonebook 
CommNet and Secure CommNet offer a built-in Phonebook that allows automated connections to frequently-used dial-up, 
Telnet and SSH2 selections. You can connect, edit or delete multiple selections. 
1. Click the Phone icon or choose Phonebook from the Communications menu. 

You may add a dial-up entry, add a Telnet entry, add a SSH2 entry, delete an entry, or modify an existing entry. Each 
entry in the Phonebook has its own connection information, terminal settings and script files.  

2. To immediately open a connection, select the entry/entries and click on Connect to selected entry(s). You may also 
open a command line connection via a Phonebook entry by typing CommNet phonebook=<entry name>.  
If a connection is made through the Phonebook, that entry’s terminal settings become the new main default. 

3. To return to the main Secure CommNet screen without attempting a connection, click on Exit Phonebook. 
4. To change a Phonebook entry’s settings, select the entry in the Phonebook and click the Edit Entry(s) button. 
 

 The Toolbar offers quick access to frequently used commands and applications. For details, see “Customizing Secure 
CommNet” on page 13. 

 
Opening a Dial-up Window 
1. Click the Dial Up icon or choose Open Dial-up Window from the Communications menu. 

When one or more dial-up entries are selected to attempt connection through the Phonebook, each entry will be dialed in 
a cyclic fashion until a connection is established. 

2. The modem initialization string is automatically transmitted. 
 
Disconnecting the Modem (Dial-up Connections Only) 
Choose Hangup Modem from the Communications menu. This should only be used in dial-up connections and will only 
work with modems which recognize the RS-232 Data Terminal Ready (DTR) signal. 
 
Opening a Telnet Connection 
1. Connect to the Internet. 
2. Click the Telnet icon or choose Open Telnet Connection from the Communications menu. 

When one or more Telnet entries are selected to attempt connection through the Phonebook, multiple session windows 
are immediately opened for connection establishment. If any dial-up entries are also selected in this group of entries, 
they are ignored. 

3. Type the destination Internet host name/IP address and port number. The default port number is 23, the standard port 
number for the Telnet protocol. Other port numbers may be specified if desired. For additional security, you may click 
the Clear History button to erase the history list.  

4. Click OK. 
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Opening a Secure Connection with Secure CommNet 

 
Connecting via SSH2 
SSH (Secure SHell) is a protocol that enables encrypted connections to remote computers, including password transmissions 
and file transfers. 
1. Click the SSH2 icon or choose Open SSH2 Connection from the Communications menu.  
2. Type the destination Internet host name/IP address and port number. The default port number is 22, the standard port 

number for the SSH2 protocol. Other port numbers may be specified if desired. For additional security, you may click 
the Clear History button to erase the history list. 

3. Type the user name and password. Click OK. 
 

 
 
Setting the SSH2 Preferences 
1. Choose SSH2 Settings from the Setup menu. The SSH2 Settings dialog box appears. 
2. Select the preferred encryption algorithm from the list. Use the up and down arrows to set the order of the encryption 

algorithms used by Secure CommNet. Then select the default message authentication code type and compression type.  
3. Click OK to retain the settings. 
 
Secure CommNet supports the following encryption algorithms:  
♦ AES256 256-bit key  CBC Mode 
♦ Twofish 256-bit key  CBC Mode 
♦ Blowfish 128-bit key  CBC Mode 
♦ Triple-DES 192-bit key  CBC Mode 
♦ Arcfour 128-bit key  RC4 Mode 
♦ Cast-128 128-bit key  CBC Mode 
 
Secure CommNet supports the following HMAC (Keyed-Hash Message Authentication Code) algorithms:  
♦ HMAC-SHA1 160-bit value 
♦ HMAC-MD5 128-bit value 
 
TCP/IP Port Forwarding (also known as Connection Tunneling) 
With TCP/IP port forwarding, you can use other TCP/IP applications over an encrypted connection for security. For more 
information about using the Tunnelier utility, visit the Bitvise website at www.bitvise.com. 
1. Open a secure connection via SSH2. 
2. Click on the Tunnel icon or choose SSH2 Tunnelier from the Tools menu. The Bitvise Tunnelier: SSH2 TCP/IP 

connection forwarder dialog box appears. 
3. Select the preferred encryption algorithm, default message authentication code type and compression type.  
4. Click Start SSH2 session with these settings. 
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Sending & Receiving Files 
 
Setting the File Transfer Protocols 
♦ To select Zmodem as the file transfer protocol for receiving and sending files, choose Zmodem Protocol from the 

Transfers menu. Crash recovery is supported. We recommend using this protocol for file transfers. 
♦ To select Ymodem-G as the file transfer protocol for receiving and sending files, choose Ymodem-G Protocol from the 

Transfers menu. Any existing files will be overwritten during receive. This should only be used in cases where the 
connection is considered to be error-free (i.e. modem has hardware error correction enabled). 

 
Setting Zmodem File Transfer Preferences 
1. Select the Automatically Detect and Start Zmodem Downloads option from the Transfers menu to automatically 

recognize the sender and start downloading files. 
2. Select the Overwrite Files During Zmodem Downloading option from the Transfers menu to automatically overwrite 

an existing file. 
 
Sending Files 
1. Click the Send icon or choose Send File from the Transfers menu. A file upload window opens where files can be 

specified and transmitted. The currently selected file transfer protocol will be used for sending.  
2. Files can be added to the upload list through the usual file selection dialog box or dragged and dropped in from the 

Windows Desktop.  
This command is available for dial-up, Internet Telnet and SSH2 sessions. Internet Telnet and SSH2 connections can 
only use Zmodem file transfers. 

3. Click OK to send the files. 
 
Setting the Receive Directory 
You can specify the preferred drive and directory where received files will be stored. 
1. Choose Set Receive Directory from the Transfers menu. The Select Receive Directory dialog box appears. 
2. Set the preferred drive and directory in which to receive files. The filename entry in the dialog box is ignored and should 

not be changed. 
3. Click OK to save your preferences. 
 
Receiving Files 
CommNet and Secure CommNet allow users to receive files using both Ymodem-G and Zmodem file transfers for dial-up 
sessions. Only Zmodem file transfers are supported for Internet Telnet and SSH2 connections.  
1. Click the Receive icon or choose Receive Files from the Transfers menu after the sender has started the transfer process. 
2. Files are downloaded using the selected file transfer protocol into the selected receive directory.   
 
Opening a FTP Session 
During a Telnet or SSH2 connection, you can open an FTP session to transfer files.  
1. Click the FTP icon or choose Open FTP Session from the Transfers menu. 
2. CommNet and Secure CommNet will launch your default FTP program to your currently active host. 
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Using Scripts 

 
Script files allow users to automate the sending of data to a remote host. It involves a user-definable sequence of commands 
that allows you to wait for and then transmit specific data. One example is to automatically login and transmit a user name 
and password for each Phonebook entry. When using the Telnet Host Mode Server, users can also customize a greeting when 
a remote user connects to their system. 
 
Creating a Script File 
1. Choose Create from the Script menu. The Input Script File to Create dialog box appears. 
2. Type a filename and click Save. The Notepad editor appears. 
 
The following commands are available: 
♦ WAIT <space> <string> Waits for the specified <string> sequence before going 

to the next script command 
♦ SEND <space> <string> Immediately sends the specified <string> sequence 
♦ DISPLAY <space> <string> Displays the specified <string> sequence without 

sending it to the host 
♦ PAUSESECONDS <space> <number of seconds> Waits a specified number of seconds before going on to 

the next script command 
♦ BEGINCAPTURE <space> <filename> 
 

Immediately starts the <filename> session capture by 
overwriting any existing capture file 

♦ BEGINCAPTUREAPPEND <space> <filename> Immediately starts the <filename> session capture by 
adding to the capture file 

♦ ENDCAPTURE Immediately ends the session capture 
♦ SETRECEIVEDIRECTORY <space> <directory 

path> 
Changes the destination directory for incoming file 
transfers. 

♦ ZMODEMUPLOAD <space> <filename> Begins sending a file via Zmodem 
♦ RUNAPPNOWAIT <space> <program name> 

<optional program parameters> 
Starts another program on the system without waiting 
for it to finish.  Example: 

RUNAPPNOWAIT C:\WINDOWS\NOTEPAD.EXE 
♦ RUNAPPANDWAIT <space> <program name> 

<optional program parameters> 
Starts another program on the system and waits for it to 
finish before continuing onto the next script command 

♦ RUNSCRIPT <space> <filename> Passes control from the current script file to a new 
script file 

♦ EXIT PROGRAM Exits Secure CommNet 
 
The following character keys can be used when defining string sequences: 
♦ ^   Control Key Sequence ♦ ^M   Carriage Return 
♦ ^[  Escape Character ♦ ^J    Line Feed 
 
Sample Script File contents: 
WAIT login: 
SEND my_username^M 
WAIT password: 
SEND my_password^M 
 

 Lines beginning with '//' are ignored. You may type notes and explanations by prefixing them with ‘//’. 
 
Editing a Script File 
1. Choose Edit from the Script menu. The Select Script File to Edit dialog box appears. 
2. Select a script file and click Open. The Notepad editor appears. 
 
Running a Script File 
At any time during a connected session, you can select Run from the Script menu to run an existing script file. The name of 
the script file will appear in the session window title bar.  
 
Stopping a Script File 
To stop a script file, select Stop from the Script menu. 
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Using Session Commands 
 
Starting a Session Capture  
To save an active window session to a file: 
1. Choose Begin Capture from the File menu. 

A Capture ON status indicator is displayed for sessions currently being captured and when the window is active. This 
menu item changes to Stop Capture when capturing is on.  

2. When the session is complete or you want to end a session capture, choose Stop Capture from the File menu. 
 

 CommNet and Secure CommNet support URL parsing, which allows you to left-click on a URL to launch the default web 
browser. You can also double-click on a word to automatically select the entire word. 

 
Transmitting Files without Character Conversion or File Protocol 
CommNet and Secure CommNet allow you to send any binary or ASCII data file to a remote host without any character 
conversion or file protocol.  
1. Choose Transmit File from the File menu. The Select File to Transmit dialog box appears.  
2. Select a file to transmit and click Open. 
 
Saving the Current Session or Selected Text 
With CommNet and Secure CommNet, you can save the current session and selected text to a file. 
1. To save the current contents (including scrollback buffer contents) of the active window session, choose Save Current 

Session from the File menu. 
2. To save the currently selected text, choose Save Selected Text from the File menu. 
3. Type in a new filename and click OK. 
 
Setting the Printer Preferences 
1. Select Printer Font from the File menu to set the font type and size for print operations. 
2. Select Printer Setup from the File menu to configure and select your preferred printer for print operations. 
 
Printing Pages, Sessions, & Selected Text 
You can print the current page, current session contents, and currently selected text.  
1. To print the current page contents of the active window, click the Print icon or choose Print Current Page from the 

File menu. 
2. To print the current contents (including scrollback buffer contents) of the active window session, choose Print Current 

Session from the File menu. 
3. To print the currently selected text, choose Print Selected Text from the File menu. 
4. Specify the number of copies you want to print and the page range. Select your printer options if necessary. Click OK. 
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Hosting a Telnet Connection 
 
CommNet and Secure CommNet can act both as a Telnet client and server. The Telnet Host Mode Server allows other 
computers to Telnet to your system. You can communicate and transfer files directly with other users, using any Telnet client 
such as CommNet or Secure CommNet. 
 

 By hosting a Telnet connection, you can chat with multiple people simultaneously (without long-distance charges) and 
transfer files directly, rather than transferring files via ftp or through a third-party server. 

 
Hosting a Telnet Connection 
1. Choose Start Telnet Host Mode Server from the Communications menu. The Telnet Host Mode Server dialog box 

appears. 
 

 
 
2. The default server port number is 23, which is the standard port number for the Telnet protocol. Click Update to specify 

other port numbers. 
3. You can specify a script file that will be run each time a client connects to your machine by clicking on Browse and 

selecting the desired script file. 
4. When a remote user connects to your system, a new session window will be created. Multiple users can connect to your 

server at the same time. 
 
Closing the Telnet Host Mode Server 
Double-click the Telnet button at the top left of the Telnet Host Mode Server session window. This will prevent new clients 
from connecting to your system, but will not disconnect existing sessions. 
 
 
 

Working with Multiple User/Network Environments 
 
On single-user systems, the CommNet or Secure CommNet registration code is stored in the Windows Registry for each 
individual user. In a multiple user/network environment, the software registration code can be stored in a single file, 
license.dat, so that each user does not have to re-register the software. 
1. Unzip and save the registration code (*.reg) on your hard drive. 
2. Right-click on the *.reg file and choose Open With – Notepad. 
3. Copy and paste the entire registration code after "Key"=, excluding the quotation marks, into a new Notepad file.  

Note: The registration code is one long text string; there should be no line breaks. 
 

 
 
4. Save the new file as license.dat in the \Program Files\Radient\CommNet or \Program Files\Radient\Secure CommNet 

folder on your hard drive. 

S A M P L E   C O D E
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Customizing the Software 
 
Customizing the Main Screen 
You can change the location of the Toolbar and Applications toolbar. To move a toolbar, drag the move handle on a 
docked toolbar or drag the title bar on a floating toolbar to another location. To return the toolbars to their default locations, 
choose Reset Toolbars from the View menu. 
 
Setting the Font, Background Color, & Text Color 
To change the font, background color or text color of the currently active window session (and all new sessions): 
1. Choose Font, Background Color or Text Color from the View menu. Note: CommNet and Secure CommNet use the 

standard color picker for simplified color control. 
2. Select the new font, background color or text color and click OK. 
 
Setting the Default Session Rows/Columns 
1. Choose Default Session Rows/Column from the Setup menu.  
2. Click on the default number of rows and columns to be used for session windows. You may choose from 24x80, 24x132, 

25x80, 25x132, 35x80, 35x132, 50x80, 50x132 and Last Window Size.  
If the session window is maximized, this setting will not be in effect; the number of rows and columns will be based on 
the size of the main program window. 

 
Setting the Scrollback Buffer 
To set the scrollback buffer size (up to 500 pages): 
1. Choose Default Scrollback Buffer Size from the Setup menu. 
2. Enter the default number of scrollback buffer pages (up to 500) and click OK. 
 
Changing Sound Effects & Adding Custom Sound Effects 
CommNet and Secure CommNet can associate program events with custom sound effects. A multimedia-capable sound card 
is required to play sound effects. You may also use your PC’s speaker beep or disable all sound effects. 
1. Copy new WAV sound files into the Secure CommNet directory.  
2. Choose Sound Effects from the Setup menu. 
3. Select an event from the Event list and a sound effect from the Sound File to Play list and click OK. 
 
Customizing the Keyboard 
You can change the key sequence sent by when pressing a numeric keypad key and special purpose key (i.e. arrow keys, 
Page Up, Page Down, etc..). The key sequence can be a set of characters and control-key presses.  
1. Choose Keyboard Mapping from the Setup menu. 
2. Select the emulation type. Each type has its own keyboard mapping. 
3. To enter a multi-line sequence, press Enter at the end of each line. You can move through the sequence by clicking on 

the scroll arrows. Click Done. 
 
Setting the Keypad Mode 
To change the keypad mode, choose Keypad from the Setup menu and select Numeric (more common) or Application 
(mapped keys). You may also press ESC> to select the Numeric keypad or ESC= to select the Application keypad. 
 
Customizing the Function Keys 
1. Choose Function Keys from the Setup menu.  
2. Select and edit the function keys to transmit specified strings.  
3. Click OK. 
 
Printing Directly from the Remote Host 
With CommNet and Secure CommNet, you can bypass the Windows printer driver during attached file printing operations. 
All data from the remote host is spooled directly to the printer. To enable or disable this function, select the Bypass Printer 
Driver for Attached Printing option from the Setup menu. 
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Using CommNet & Secure CommNet with WWW Browsers 
 
CommNet and Secure CommNet can be used as the Telnet client application for a World Wide Web (WWW) browser. 
Simply set your WWW browser to point to the CommNet or Secure CommNet executable file COMMNET.EXE. 
 

 Microsoft Internet Explorer users: You must edit the “URL: Telnet Protocol” file type to perform an “open” action on 
the COMMNET.EXE application. 

 
 
 

Running CommNet & Secure CommNet from MS-DOS  
 
CommNet and Secure CommNet can be directly run from the Program Manager or from the MS-DOS command prompt to 
connect to a dial-up modem or Telnet/SSH host. Three types of command line connections are supported.  
 

 Adding the CommNet or Secure CommNet directory to your system PATH environment variable will allow you to run the 
software from any directory. 

 
1. Connecting via a Phonebook entry: CommNet phonebook=<entry name> 

<entry name> is a Phonebook entry  
 
The following optional parameters will override any existing settings in the phonebook entry: 
host=<hostname> is the Internet address for the host to connect to 
port=<port> is the port number to connect to on the host. If a port number is not specified, Secure CommNet defaults to 
port 23 for Telnet and port 22 for SSH2 connections. 
username=<username> is the user name 
password=<password> is the password 
script=<scriptfile> is the name of a script file to run after connection has been established with the host  

 
2. Connecting to a Telnet/SSH system via a hostname: CommNet host=<hostname>  

host=<hostname> is the Internet address for the host to connect to 
 
The following optional parameters are available: 
port=<port> is the port number to connect to on the host. If a port number is not specified, Secure CommNet defaults to 
port 23 for Telnet and port 22 for SSH2 connections. 
username=<username> is the user name (required for SSH2 connections) 
password=<password> is the password (required for SSH2 connections) 
ssh is used to specify a SSH2 connection instead of Telnet 
script=<scriptfile> is the name of a script file to run after connection has been established with the host  

 
3. Connecting via a Telnet URL: CommNet <telnet URL> 

<telnet URL> can be “telnet://hostname:port” or “telnet://hostname”  
If a port number is not specified, Secure CommNet defaults to port 23. 

 
In all cases, if no parameters are specified, Secure CommNet will load normally without connecting to any hosts.  
 

 For all connection types, the config=<directory name> parameter can be used to specify the location of the Secure 
CommNet configuration files. The default location for the configuration files is in the Secure CommNet program 
directory. 

 
 



15 

Frequently Asked Questions (FAQs) 
 

What is Telnet? 
Telnet is an Internet Protocol used to connect to remote host computers.  

What is SSH? 
SSH (Secure SHell) is a protocol that enables encrypted connections to remote computers, including password transmissions 
and file transfers.  

Can I use CommNet and Secure CommNet on a computer with multiple users? 
Yes. The software registration code can be stored in a single file, license.dat, so that each user does not have to re-register 
the software. Simply open your existing registration file (*.reg) with Notepad. Copy and paste the entire registration code 
after “Key”=, excluding the quotation marks, into a new Notepad file. Save the new file as license.dat in your \Program 
Files\Radient\CommNet or \Program Files\Radient\Secure CommNet folder.  

How can I change the font size to get a full-screen display? 
Choose Font from the View menu and change the font style to a True Type font, which is scalable to any point size. A larger 
point size will use up more of the screen display. To display ANSI graphics or VT100 line drawing, you must use either the 
Secure CommNet font or the Terminal font.  

What is PC ANSI? 
PC ANSI emulation is comprised of 8-bit coded characters and commands that are commonly used on bulletin board 
systems. PC ANSI emulation is capable of displaying color text and graphics.  

Why can’t I see PC ANSI graphics, SCO ANSI graphics, or VT100 line drawing properly? 
To properly see PC ANSI graphics, SCO ANSI graphics, and VT100 line drawing, the Secure CommNet font or the Terminal 
font should be selected. Any equivalent font that supports the IBM Extended ASCII character set may also be used. 

Why can't I see the characters I type? 
The reason why you are not seeing the characters you type is because your "local echo" terminal setting is probably turned 
off. What you need to do is go to "Setup-Terminal Settings" and turn it on. If you are using Phonebook entries to connect, 
you need to edit each entry's terminal settings since every Phonebook entry has its own terminal settings. 

Why do I see double characters when I type? 
The reason why you are getting double characters is because your "local echo" terminal setting is probably turned on. What 
you need to do is go to "Setup-Terminal Settings" and turn it off. If you are using Phonebook entries to connect, you need to 
edit each entry's terminal settings since every Phonebook entry has its own terminal settings. 

I've connected to a site but the Enter key does not seem to be working. What is wrong? 
The most likely reason why pressing the Enter key is not working is because the remote host requires a carriage return-line 
feed (CR-LF) combination when pressing the Enter key. What you need to do is go to "Setup-Terminal Settings" and turn on 
"outbound CR->CR-LF conversion". If you are using Phonebook entries to connect, you need to edit each entry's terminal 
settings since every Phonebook entry has its own terminal settings. 

How do I use Secure CommNet with America Online (AOL)? 
After installing Secure CommNet, connect to AOL version 3.0 or later. Start Secure CommNet and open a Telnet or SSH2 
connection. 

Another user has connected to my computer via Telnet Host Mode Server but they can’t see what they are typing. 
What are the proper settings he/she should be using? 
The Telnet client that connects to Secure CommNet should have "Local Echo" turned on and should send "Carriage Return 
+ Linefeed" sequences when pressing Enter (in Secure CommNet terms, Outbound CR->CR-LF conversion should be 
ON). The easiest way to ensure compatibility is to have the other user use Secure CommNet as the Telnet client. 
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Reference: Keyboard Mapping 
 
TTY Terminal Emulation 
No default keyboard mapping is used for the TTY terminal emulation mode. 
 
VT100/VT220 Terminal Emulation 
The following default keyboard mapping escape sequences are used for the VT100/VT220 terminal emulation modes (^[ represents the escape character 1B 
hex): 
 
Arrow Keys  Transmitted Escape Sequence 
Up Arrow   ^[OA (Application Cursor Up) 
Down Arrow  ^[OB (Application Cursor Down) 
Right Arrow  ^[OC (Application Cursor Right) 
Left Arrow  ^[OD (Application Cursor Left) 
  
Numeric Keypad  Transmitted Escape Sequence with Application Keypad mode ON 
0   ^[Op (Keypad Application 0 - Num Lock ON) 
1   ^[Oq (Keypad Application 1 - Num Lock ON) 
2   ^[Or (Keypad Application 2 - Num Lock ON) 
3   ^[Os (Keypad Application 3 - Num Lock ON) 
4   ^[Ot (Keypad Application 4 - Num Lock ON) 
5   ^[Ou (Keypad Application 5 - Num Lock ON) 
6   ^[Ov (Keypad Application 6 - Num Lock ON) 
7   ^[Ow (Keypad Application 7 - Num Lock ON) 
8   ^[Ox (Keypad Application 8 - Num Lock ON) 
9   ^[Oy (Keypad Application 9 - Num Lock ON) 
Num Lock   ^[OP (Program Function 1 - PF1) 
Divide Key  ^[OQ (Program Function 2 - PF2) 
Multiply Key  ^[OR (Program Function 3 - PF3) 
Subtract Key  ^[OS (Program Function 4 - PF4) 
Add Key   ^[OM (Keypad App. Enter) 
Decimal Key  ^[On (Keypad App. Period - Num Lock ON) 
 
Miscellaneous Keys  Transmitted Escape Sequence 
Insert   ^[[L (Insert Line) 
Delete   DEL [Hex 7F] 
Home   ^[[H (Home Cursor) 
End   ^[[K (Erase End of Line) 
Page Up   ^[[M (Delete Line) 
Page Down  ^[[H^[[2J (Clear Screen) 
 
PC ANSI Terminal Emulation 
The following default keyboard mapping escape sequences are used for the PC ANSI emulation mode: 
 
Arrow Keys  Transmitted Escape Sequence 
Up Arrow   ^[[A  
Down Arrow  ^[[B  
Right Arrow  ^[[C  
Left Arrow  ^[[D  
 
Miscellaneous Keys  Transmitted Escape Sequence 
Insert   ^[[L   
Delete   DEL [Hex 7F] 
Home   ^[[H  
End   ^[[K  
Page Up   ^[[M 
Page Down  ^[[2J 
 


